Changes between Version 20 and Version 21 of DeveloperGuidlines


Ignore:
Timestamp:
Oct 25, 2009, 12:14:55 PM (12 years ago)
Author:
Matthäus Wander
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • DeveloperGuidlines

    v20 v21  
    1616Since !CrypTool 2.0 is based on Microsoft .NET 3.5, you first need a Microsoft Windows environment. (Right now no plans exist for porting this project to mono and therefore other platforms.) WE successfully tested with '''Windows XP''' and '''Windows Vista'''. 
    1717
    18 Since you're reading the developer guidlines, you probably want to develop something. Hence you need a developer environment. In order to compile our sources you need '''Microsoft Visual Studio 2008 Professional'''. Please make sure you always install the latest service packs for Visual Studio too. Unfortunately it does not work (smoothly) with the freely available Visual Studio Express (C#) versions. This is due to the fact, that !CrypWin uses a commercial component, and is therefore distributed only as binary. The C# Express version unfortunately cannot handle a binary as a start project, hence debuggin becomes cumbersome.
     18Since you're reading the developer guidlines, you probably want to develop something. Hence you need a developer environment. In order to compile our sources you need '''Microsoft Visual Studio 2008 Professional''' or '''Team System'''. Please make sure you always install the latest service packs for Visual Studio too (the current SP1 is ''not'' automatically installed by Microsoft Update). Unfortunately it does not work (smoothly) with the freely available Visual Studio Express (C#) versions. This is due to the fact, that !CrypWin uses a commercial component, and is therefore distributed only as binary. The C# Express version unfortunately cannot handle a binary as a start project, hence debuggin becomes cumbersome.
    1919
    2020Usually the installation of Visual Studio also installs the .NET framework. In order to run/compile our source code you need (at the time of this writing) at least '''Microsoft .NET 3.5 with Service Pack 1 (SP1)'''. You can get this freely from Microsofts [http://download.microsoft.com/download/2/0/e/20e90413-712f-438c-988e-fdaa79a8ac3d/dotnetfx35.exe webpage].