Opened 12 years ago

Closed 12 years ago

#97 closed Bug (fixed)

SizeChanged-Event does not always fire when presentation gets resized

Reported by: Arno Wacker Owned by: Thomas Schmid
Priority: Should be done Milestone:
Component: AnotherEditor Keywords:
Cc:

Description

Howto reproduce:

  • Open FrequencyAnalysis sample and run it
  • Resize the Unigram analysis to a smaller size. Result it zoomes and everything becomes smaller.
  • Resize it now again by making it bigger. Expected result: everything should zoom bigger again, actual result: it stays with the small size.

Reason: The SizeChanged-Event does not fire, when the presentation space becomes bigger than the space needed by the usercontrol. It seems like the child-control (i.e. the presentation-usercontrol) is not set to fill out all space given, and therefore does not resize when the parent resizes)

Change History (2)

comment:1 Changed 12 years ago by Arno Wacker

(In [706]) Cosmetic changes to frequency test Presentation

  • Replaced the StackPanel with Grid to gain more control over placing elements
  • Added ChartHeight-settings, in case Autozoom is not used
  • Headline is now dynamically adapted depending on gram-length used.
  • In autozoom mode the chart now also adapts if the number of character changes during play (see e.g. the enigma-analyzer samples)
  • Added a slider to the settings for scaling - currently duplicates the slider in the presentation; maybe the in-presentations slider can be removed later (open: when moving the in-presentation-slider, the settings-slider does not move yet - not implemented)
  • Resize bug still open, no solution found yet, see #97
  • Updated the sample to avoid loading-warnings

comment:2 Changed 12 years ago by Arno Wacker

Resolution: fixed
Status: newclosed

(In [738]) * Fixed autozoom feature of frequency test; finally seems to work in all cases - this closes #97, after all it was not an editor bug, but a missing "Stretch" in the FrequencyTest-presentation.

  • Removed the zoom-slider from presentation. Zoom/Scale is now accessible only in the settings (usually not needed, since autozoom is default)
  • Re-introduced ProgressChanged (faked, it just become fully green when done)
  • Changed Background to LightYellow in Run-mode and LightGray when stopped. This way it does not interfere with the progress-green.
  • Updated samples using FrequencyTest to avoid loading warnings.
Note: See TracTickets for help on using tickets.