Opened 12 years ago

Closed 12 years ago

Last modified 10 years ago

#96 closed Bug (fixed)

Preset CrypWin settings LastPath and LastFile may point to non-existent directory

Reported by: Matthäus Wander Owned by: Thomas Schmid
Priority: Must have Milestone:
Component: Installer Keywords:
Cc: kopal

Description

When installing CT2 to some arbitrary folder, the LastPath and LastFile settings point anyway to >c:\Programme\CrypTool 2 beta\SampleProjects\. The file dialog can't find this folder and falls back to some folder in home directory. A user reported that he assumed there were no samples provided.

The path should either be relative or be set dynamically by installer subject to the chosen installation path.

Change History (5)

comment:1 Changed 12 years ago by Arno Wacker

Milestone: CrypTool 2.0 (Release)
Priority: Should be doneMust have

comment:2 Changed 12 years ago by Arno Wacker

Resolution: fixed
Status: newclosed

(In [1248]) Fixes for initial sample opening and initial setting for Samples-directory. This closes #96, please re-open if the issue described is not fixed!

CrypWin:

  • Old configuration is now no longer "forgotten" with a new version, but internally upgraded.
  • The samples directory is dynamically determined: CrypWin will search the application-dir/ProjectSamples and the application-dir/../../../ProjectSamples (SVN-case). The application-dir/ProjectSamples has precedence over the SVN version.
  • In case the last opened sample was removed (i.e. is not found), CrypWin will fall back to the default sample.

New binaris for CrypWin (Release/Debug)

comment:3 Changed 12 years ago by Matthäus Wander

thanks.

comment:4 Changed 11 years ago by Arno Wacker

(In [1898]) CrypWin:

  • Changed start-up behavior when searching for the project samples directory: Due to changes in the build process, it is no longer necessary to differentiate between SVN and deploy case. Hence CryWin always searches for "ProjectSamples" in the application directory. In case this is not found (should happen only if installation is broken) the Desktop-directory is used, to prevent from unexpected behavior. This refs #96.
  • New binaries (x86/x64) of CrypWin and AnotherEditor, which include also changes from rev 1886 (open dialog now filters for all editor types at once)

comment:5 Changed 10 years ago by Matthäus Wander

Milestone: CrypTool 2.0 RELEASE
Note: See TracTickets for help on using tickets.