Opened 11 years ago

Closed 11 years ago

#225 closed Bug (fixed)

IControl does not work with WorkspaceManager

Reported by: Arno Wacker Owned by: matkovic
Priority: Must have Milestone: CrypTool 2.0 BETA 4
Component: WorkspaceManager Keywords:
Cc: kopal, Sven Rech

Description

When creating a new project using the WorkspaceManager and one of the functions requires an IControl connection, the projects cannot work, since the IControl connection is not established.

Howto reproduce:

  • Make a new project with any IControl-Master
  • Drag and drop the salves to the IControl field of the Master
  • Make the rest of your required connections and run the workspace

Expected: It should work.

Waht really happens ist, that the master complains about a missing slave.

Additional note: If you save this project and reload it afterwards, you will find all slaves directly on the workspace, and not inside the master.

Change History (3)

comment:1 Changed 11 years ago by matkovic

Status: newaccepted

Can't reproduce the bug. Add please more information.

Last edited 11 years ago by matkovic (previous) (diff)

comment:2 Changed 11 years ago by Arno Wacker

Just use IControl with a NEW project. It does not work.

comment:3 Changed 11 years ago by kopal

Resolution: fixed
Status: acceptedclosed

(In [2876]) IControl now works - missed ConnectionModel between ConnectorModel and PluginModel fixes #225

Note: See TracTickets for help on using tickets.