Opened 11 years ago

Closed 11 years ago

#195 closed Bug (fixed)

Save buton always defaults to "Save As"

Reported by: Arno Wacker Owned by: Sven Rech
Priority: Important Milestone: CrypTool 2.0 BETA 4
Component: CrypWin Keywords:
Cc:

Description

The Save (with it's dropdown "Save" and "Save as") always defaults to "Save as".

Expected behaviour:

  • When there is no filename available, i.e. a new document or a template has been opened, it should behave like "Save as"
  • When there is a filename (usually after it has been saved once) or a normal project file has been opened, the button should default to "Save" i.e. not ask for a filename.

Change History (2)

comment:1 Changed 11 years ago by Sven Rech

This is not possible, because the ribbon stuff will disable the arrow on the right side when the save button itself is deactived (which is the case when there is no change in the open project)

comment:2 Changed 11 years ago by Sven Rech

Resolution: fixed
Status: newclosed

(In [2508]) lots and lots of changes:

  • Added Editor Settings Tab
  • language selection hard coded
  • changed tab contentchange indicator (works better like this)
  • reworked most settings tabs
  • other colors in settings
  • moved samples category in navigation pane up
  • changed save button (fixes #195)
Note: See TracTickets for help on using tickets.