Opened 11 years ago

Closed 11 years ago

#188 closed Bug (fixed)

OpenCL fails in KeySearcher with INVALID_BINARY

Reported by: Arno Wacker Owned by: Sven Rech
Priority: Important Milestone: CrypTool 2.0 BETA 4
Component: KeySearcher Keywords:
Cc:

Description

When using OpenCL for the KeySearcher this fails on some Computers with the error message "Invalid binary".

This error seems to depend on the machine. For now it is unclear under which conditions the rror occurs and under which not.

It can be reproduced with our "vs-media"-PC, since here the error is always visible. (Arch: x64, CT-x86, Win7-Pro, Nvidia 6800 GT - interesting, that on the same machine an old x64-CT2 works without problems with OpenCL).

If this problem occurs also in other environments, please provide as many as possible details about the computer, i.e. architecture, which CT2-version, which OS, which GPU)

Change History (4)

comment:1 Changed 11 years ago by Matthäus Wander

Works for me without errors. Windows 7 Pro, 64 Bit, GeForce GTX 460.

comment:2 Changed 11 years ago by Sven Rech

This is most probably a driver problem, because the appearance of this error highly depends on which gpu and which driver version you have installed.

comment:3 Changed 11 years ago by Sven Rech

See also: KeySearcher OpenCL

comment:4 Changed 11 years ago by Matthäus Wander

Resolution: fixed
Status: newclosed

fixed in r2838

Note: See TracTickets for help on using tickets.