Opened 11 years ago

Closed 11 years ago

#185 closed Bug (invalid)

KeySearcher: High load during statistics update

Reported by: Arno Wacker Owned by: nolte
Priority: Important Milestone: CrypTool 2.0 BETA 4
Component: KeySearcher Keywords:
Cc: Sven Rech

Description

After reading all data from the DHT, the KeySearcher performs some local operations before starting to calculate. This seems to take a very long time (minutes) and uses high CPU load. Additionally, it seems, that reserving the block to be calculated happens AFTER that time. Therefore slow(er) clients almost always loose the identified block, since somebody else registered already for calculating this block.

Howtofix:

  • Reduce load for statistics calculation
  • Make the reservation of a block, immediately after indetifying which block should be calculated

Change History (2)

comment:1 Changed 11 years ago by nolte

Status: newaccepted

comment:2 Changed 11 years ago by nolte

Resolution: invalid
Status: acceptedclosed

-Payload for statistic is minimal -Calculation time doesn't influence reservation process -Can't be reproduced

Note: See TracTickets for help on using tickets.