Opened 11 years ago

Closed 11 years ago

#184 closed Bug (fixed)

KeySearcher hangs, if the connection is lost during communication with the network

Reported by: Arno Wacker Owned by: Sven Rech
Priority: Must have Milestone: CrypTool 2.0 BETA 4
Component: KeySearcher Keywords:
Cc: kopal

Description

The keysearcher does not recover from a lost connection if the connection is lost during the phase where results are stored or the distributed key-search-tree is searched.

Howto reproduce:

  • Start a distributed keysearcher (e.g. using the MTC3-AES65-Challenge)
  • Wait until die Keysearcher performs Retrieves/Stores on the DHT
  • Cut your Internet-connection during this time

Expected: the keysearcher should detect the loss of connection and continously try to re-establish the connection until sucessfull or stopped by the user. After connection re-establishment, the key searcher should simply go on with what it was doing before the connection-loss-event.

What actually happens: The connection is lost, the KeySearcher detects this and tries to re-establish. However, the re-establishment never succeeds (nor timeouts for that matter) and the entire CrypTool 2.0 hangs. At this point you can kill CrypTool only with the taskmanger, since also stop is no longer possible.

This happens with the WebDHT. Not tested with Chord. Please make extensive tests about connection failures - this must become robust.

Change History (2)

comment:1 Changed 11 years ago by Sven Rech

Already solved by a dirty hack in the p2p operations. But a better solution for this is still wanted.

comment:2 Changed 11 years ago by Sven Rech

Resolution: fixed
Status: newclosed

The problem can't be reproduced anymore.

Note: See TracTickets for help on using tickets.