Opened 11 years ago

Closed 11 years ago

Last modified 10 years ago

#156 closed Bug (fixed)

Internal solution does not compile

Reported by: Arno Wacker Owned by: coredevs
Priority: Must have Milestone:
Component: General Keywords: Compile error
Cc:

Description

When trying to compile the internal solution, you get the follwoing error messages:

Error 92 The type or namespace name 'CrypWin' does not exist in the namespace 'Cryptool' (are you missing an assembly reference?) C:\Users\Arno Wacker\Desktop\CrypTool 2.0\Repository\trunk\CrypStartup\App.xaml.cs 17 22 CrypStartup

Error 93 The type or namespace name 'CrypWin' does not exist in the namespace 'Cryptool' (are you missing an assembly reference?) C:\Users\Arno Wacker\Desktop\CrypTool 2.0\Repository\trunk\CrypStartup\App.xaml.cs 17 60 CrypStartup

Error 311 Member 'Cryptool.P2P.P2PManager.IsAutoconnectConsoleOptionSet.get' cannot be accessed with an instance reference; qualify it with a type name instead C:\Users\Arno Wacker\Desktop\CrypTool 2.0\Repository\trunk\CoreDeveloper\CrypWin\MainWindow.xaml.cs 242 9 CrypWin

Error 312 Member 'Cryptool.P2P.P2PManager.HandleConnectOnStartup()' cannot be accessed with an instance reference; qualify it with a type name instead C:\Users\Arno Wacker\Desktop\CrypTool 2.0\Repository\trunk\CoreDeveloper\CrypWin\MainWindow.xaml.cs 243 9 CrypWin

Error 313 'Cryptool.P2P.P2PManager' does not contain a definition for 'HandleShutdown' and no extension method 'HandleShutdown' accepting a first argument of type 'Cryptool.P2P.P2PManager' could be found (are you missing a using directive or an assembly reference?) C:\Users\Arno Wacker\Desktop\CrypTool 2.0\Repository\trunk\CoreDeveloper\CrypWin\MainWindow.xaml.cs 1624 37 CrypWin

Change History (3)

comment:1 Changed 11 years ago by Matthäus Wander

Please update and try again. May have been caused by an SVN access control change (* = r considered harmful).

comment:2 Changed 11 years ago by Matthäus Wander

Resolution: fixed
Status: newclosed

Yep, caused by global SVN read access -> HTTPS+SVN server did not demand 401 HTTP authorization and thus TortoiseSVN did not attempt to send login. Without login, CoreDeveloper has not been updated, which lead to an inconsistent state.

comment:3 Changed 10 years ago by Matthäus Wander

Milestone: CrypTool 2.0 RELEASE
Note: See TracTickets for help on using tickets.