Opened 12 years ago

Closed 12 years ago

Last modified 10 years ago

#135 closed Bug (fixed)

Dispose() of plugins is not called when terminating CrypWin

Reported by: Arno Wacker Owned by: Matthäus Wander
Priority: Must have Milestone:
Component: AnotherEditor Keywords:
Cc:

Description

When CrypTool2 (CrypWin.exe) gets closed (e.g. by clicking the close button), the dispose method of each plugin should be called, in order to provide the ability for a clean exit.

Obeserved behaviour: Dispose() is not called

How to reproduce: 1.) Open the public solution of CrypTool2 and set a breakpoint in P2PPeer.cs in line 131 (first line of the Dispose()-method) 2.) Compile and start CrypTool and load the sample CeBIT-P2P-Maanger.cte 3.) Click on Play and wait for the P2P-System to become green (logged in) 4.) Close CrypTool2

Expected: VS should stop in your breakpoint. Result: Breakpoint is never reached, but CrypWin never terminates (GUI is gone, but VS studio remains on running - which is kind of right, since the p2p-system was never shutted down..)

This bug refers to the current SVN-version.

Change History (2)

comment:1 Changed 12 years ago by Matthäus Wander

Resolution: fixed
Status: newclosed

(In [1246]) bugfix for Dispose(), fixes #135

comment:2 Changed 10 years ago by Matthäus Wander

Milestone: CrypTool 2.0 RELEASE
Note: See TracTickets for help on using tickets.