Opened 12 years ago

Closed 11 years ago

Last modified 10 years ago

#132 closed Bug (wontfix)

DeleteConnectionCommand.cs throws NullReferenceException

Reported by: arnold Owned by: Thomas Schmid
Priority: Important Milestone:
Component: AnotherEditor Keywords:
Cc:

Description

Reproduce this Exception: Open P2P_OnePubTwoSubs_Sample.cte and mark everything but the three upper PlugIns (TextInput, P2P_Publisher, P2PPeer). Then delete this six PlugIns --> a NullReferenceException will be thrown in DeleteConnectionCommand.cs --> Execute().

This Exception will only be thrown, when you want to delete the six PlugIns COMBINED, all other cases work unproblematic.

Remark: You have to add the two projects PeerToPeerPublisher and PeerToPeerSubscriber in your own solution. In the common solution they were already added.

Change History (3)

comment:1 Changed 11 years ago by Matthäus Wander

Test whether this occurs with new WorkspaceManager. When not, close as wontfix.

comment:2 Changed 11 years ago by Matthäus Wander

Resolution: wontfix
Status: newclosed

Can't reproduce in WorkspaceManager. Won't fix in AnotherEditor.

comment:3 Changed 10 years ago by Matthäus Wander

Milestone: CrypTool 2.0 RELEASE
Note: See TracTickets for help on using tickets.