Opened 12 years ago

Closed 11 years ago

Last modified 10 years ago

#105 closed Feature request (fixed)

Adding a new workspace should open a new tab

Reported by: Sören Rinne Owned by: Sven Rech
Priority: Must have Milestone:
Component: CrypWin Keywords:
Cc: Sven Rech

Description (last modified by Matthäus Wander)

When adding a new workspace, the workspace should open in a new tab, instead of overlaying the existent one. This also makes "Current workspace" dropdown menu unnecessary.

It should be possible to open multiple projects as different tabs concurrently.

Change History (14)

comment:1 Changed 12 years ago by Matthäus Wander

Agree. Christian Meyer already proposed this in his thesis paper, see issues 41 and 42 in the summary (Documentation folder).

comment:2 Changed 12 years ago by Matthäus Wander

Milestone: CrypTool 2.0 (Release)
Priority: Should be doneMust have
Type: Open taskFeature request

comment:3 Changed 12 years ago by Matthäus Wander

Description: modified (diff)

comment:4 Changed 12 years ago by Thomas Schmid

I think there are two things to decide:

  1. Should CrypWin or an editor handle the tabs. If CrypWin handles the tabs, i think we need a new event that will be used by editors to request a new (workspace)tab. If an editor handles the windows no new event is needed.

I would prefer that CrypWin handles the tabs, what do you think?

  1. AFAIK by implementing this feature the presentation tabs for plugin GUIs should be removed completely, because otherwise the presentations of different workspaces would be mixed.

This would mean, that we need a maximize feature for the plugins first, to use the presentations completely in quick watch view. But what to do with tools plugins like primes? I think a separate tab would still be a good idea for such plugins. Should tools plugins (with no I/O) still have a plugin icon on workspaces? Maybe it's an good idea to open this plugins just once? If yes, who should monitor that only one instance of a tool plugin is open? I think this depends on decision of "1."

comment:5 Changed 12 years ago by Thomas Schmid

Status: newaccepted

comment:6 Changed 12 years ago by Matthäus Wander

  1. I second that CrypWin should handle the tabs (because for example multiple editors can be used in parallel then).
  2. Agree again, that the presentation tabs should be removed, instead quickwatch should be maximized. I'm not sure about tool plugins with no I/O. Which ones do you mean?

comment:7 Changed 11 years ago by Sven Rech

Cc: Sven Rech added

I'm working on it... There are now tabs available, but the old editor doesn't show "his" tabs there. Instead it has it's seperat tabs. I will change that later.

comment:8 Changed 11 years ago by Sören Rinne

Nice! Will it be visible in the nightly builds?

comment:9 Changed 11 years ago by Matthäus Wander

Component: AnotherEditorCrypWin
Owner: changed from Thomas Schmid to Sven Rech
Status: acceptedassigned

@Sören: yep, it is already.

@Sven: do you want to implement the "Open" button in a way that it automatically opens the chosen sample in a new tab?

comment:10 Changed 11 years ago by Sören Rinne

Issue 1: After clicking "New" a new "major" tab opens. If I open a .cte in that new tab, it get's opened in both major tabs.

Issue 2: How do I close a new tab?

Issue 3: The naming of the "major" tab is "AnotherEditor.AnotherEditor". But I guess you've already mentioned that ;)

comment:11 Changed 11 years ago by Sven Rech

Hi, first thank you for your feedback.

Issue 1: Can't simulate that. This works fine for me.

Issue 2: Now there is a possibility to do that. Check out the next nightely build. I know it looks a little bit ugly, but this can be changed later ;)

Issue 3: Fixed that.

@Wander: I changed that now.

comment:12 Changed 11 years ago by Sören Rinne

Issue 1: Can't reproduce it either.

Issue 4: After closing all "AnotherEditor" tabs, I can't open a new one. The "New", "Open", and "Save" buttons are disabled (since there is no AnotherEditor left to talk to...).

Issue 5: If I have created a new tab with the "New" button, added nothing to the workspace, and then open a .cte I feel like it should open in the current tab. Or in other words: Opening a file should always open in the current tab. Only creating a new workspace should open a new tab. Or maybe reuse the current tab only when it's empty. I'm not sure what's the "normal" behaviour in this case. Maybe the current behaviour is widely known as "normal". Maybe just discuss it with some other guys.

comment:13 Changed 11 years ago by Sven Rech

Resolution: fixed
Status: assignedclosed

Thank you. Fixed everything.

comment:14 Changed 10 years ago by Matthäus Wander

Milestone: CrypTool 2.0 RELEASE
Note: See TracTickets for help on using tickets.